Subject: [Compgeom-discuss] help.

From: <[email-masked]>
Date: 23 May 2006 15:24:25 -0500

Hello,

I am trying to find an available software in the Internet that computes 3D 
weighted voronoi diagram --- one that would take any distance function as 
input.

Thank you for any help.

---

From: Monique Teillaud <[email-masked]>
Date: Tue, 18 Jul 2006 12:11:08 +0200

Hi,

Sorry for my late answer...

There are fully dynamic 3D regular triangulations in CGAL (also known as 
weighted Delaunay triangulations).

The class CGAL::Regular_triangulation_3 is templated by a "traits class" 
parameter, where you can provide your own basic objects and predicates, 
so, you should be able to give your own distance through the power_test 
predicate. However, the algorithms implicitely assume that the distance 
function 'looks like' the weighted Euclidean distance in R^3. I am not 
sure this is what you mean by "any distance function"...

Have a look at
www.cgal.org
manual (online or ps or pdf)
Chapter 3D triangulations

Best regards,
	Monique Teillaud

[email-masked] wrote:
> 
> Hello,
> 
> I am trying to find an available software in the Internet that computes 
> 3D weighted voronoi diagram --- one that would take any distance 
> function as input.
> 
> Thank you for any help.
> 
> _______________________________________________
> Compgeom-discuss mailing list
> [email-masked]
> http://compgeom.poly.edu/mailman/listinfo/compgeom-discuss